GenerationIP

Just for you

  • Increase font size
  • Default font size
  • Decrease font size
Home Documentation General Documentation Bonding linux with cisco and LCAP

Bonding linux with cisco and LCAP

User Rating: / 1
PoorBest 

Type : System
Operating System
: Redhat,Fedora,Centos

This Howto explain how to configure Bonding or the Teaming solution on LINUX with CISCO switch with LACP.

Modprobe.conf :

alias bond0 bonding
options bond0 miimon=80 mode=4

Network interface :

[root@centos ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:29:b9:64:3d:73
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no

[root@centos ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
# Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet
DEVICE=eth1
BOOTPROTO=none
HWADDR=00:29:b9:64:3d:75
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no

[root@centos ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
USERCTL=no
IPADDR=192.168.2.20
NETMASK=255.255.255.0

Cisco switch config

Port

SSS-SR2#show run int gi0/43
Building configuration...

Current configuration : 142 bytes
!
interface GigabitEthernet0/43
switchport access vlan 172
switchport mode access
channel-group 3 mode active
spanning-tree portfast
end

SSS-SR2#show run int gi0/44
Building configuration...

Current configuration : 142 bytes
!
interface GigabitEthernet0/44
switchport access vlan 172
switchport mode access
channel-group 3 mode active
spanning-tree portfast
end

 

etherchannel :

show etherchannel 2 summary
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3      S - Layer2
U - in use      f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SU)         LACP      Gi0/45(P)   Gi0/46(P)

State of the interface :

Ethernet Channel Bonding Driver: v3.4.0 (October 7, 2008)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer2 (0)
MII Status: up
MII Polling Interval (ms): 80
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: slow
Active Aggregator Info:
Aggregator ID: 1
Number of ports: 2
Actor Key: 9
Partner Key: 3
Partner Mac Address: 00:21:1b:29:b3:00

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:29:b9:64:3d:73
Aggregator ID: 1

Slave Interface: eth1
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:29:b9:64:3d:75
Aggregator ID: 1

 

RELATED ARTICLES

Howto create promisc or promiscuous interface on redhat, fedora, centos

Advanced Configuration for bonding and teaming with vlans

 

 

 

Last Updated on Wednesday, 05 June 2013 22:17